#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n"
Local $sString = "%abstract-class {" & @CRLF & _
" font-family: Verdana;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"%abstract-class {" & @CRLF & _
" font-family: Verdana;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"%abstract-class{" & @CRLF & _
" font-family: Verdana;" & @CRLF & _
" font-site: 100%;" & @CRLF & _
"} " & @CRLF & _
"" & @CRLF & _
"bla {" & @CRLF & _
"lkdjkjd: 10px;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"%abstract-class {" & @CRLF & _
" .abstract-class {" & @CRLF & _
" font-family: Verdana;" & @CRLF & _
" }" & @CRLF & _
" a," & @CRLF & _
" a:hover {" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")