re = /%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n/
str = '%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end