use strict;
my $str = '%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
';
my $regex = qr/%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}