import Foundation
let pattern = #"%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
%George%<Croissant>|2|10.3$
%Peter%<Gum>|1|1.3$
%Maria%<Cola>|1|2.4$
%Valid%<Valid>valid|10|valid200$
end of shift
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)