$re = '/%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$/';
$str = '%George%<Croissant>|2|10.3$
%Peter%<Gum>|1|1.3$
%Maria%<Cola>|1|2.4$
%Valid%<Valid>valid|10|valid200$
end of shift
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);