const regex = /%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('%[A-Z][a-z]+%[^\\|\\$\\%\\.]*<[A-Za-z]+>\\|[0-9]+\\|[0-9]+(\\.[0-9])?\\$', 'g')
const str = `%George%<Croissant>|2|10.3\$
%Peter%<Gum>|1|1.3\$
%Maria%<Cola>|1|2.4\$
%Valid%<Valid>valid|10|valid200\$
end of shift
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}