re = /%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$/
str = '%George%<Croissant>|2|10.3$
%Peter%<Gum>|1|1.3$
%Maria%<Cola>|1|2.4$
%Valid%<Valid>valid|10|valid200$
end of shift
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end