package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$`)
var str = `%George%<Croissant>|2|10.3$
%Peter%<Gum>|1|1.3$
%Maria%<Cola>|1|2.4$
%Valid%<Valid>valid|10|valid200$
end of shift
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}