use strict;
my $str = '%George%<Croissant>|2|10.3$
%Peter%<Gum>|1|1.3$
%Maria%<Cola>|1|2.4$
%Valid%<Valid>valid|10|valid200$
end of shift
';
my $regex = qr/%[A-Z][a-z]+%[^\|\$\%\.]*<[A-Za-z]+>\|[0-9]+\|[0-9]+(\.[0-9])?\$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}