import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%[A-Z][a-z]+%[^\\|\\$\\%\\.]*<[A-Za-z]+>\\|[0-9]+\\|[0-9]+(\\.[0-9])?\\$";
final String string = "%George%<Croissant>|2|10.3$\n"
+ "%Peter%<Gum>|1|1.3$\n"
+ "%Maria%<Cola>|1|2.4$\n"
+ "%Valid%<Valid>valid|10|valid200$\n"
+ "end of shift\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}