re = /[\'\"](.*)[\'\"]\s*=>\s*(.*),*\s/m
str = '\'Default - Auto\' => \'\',
\'Cover\' => \'cover\',
\'Contain\' => \'contain\', '
subst = '$2\\t\\t\\t\\t\\t\\t=> __(\'$1\', \'default\'),\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result