use strict;
my $str = '\'Default - Auto\' => \'\',
\'Cover\' => \'cover\',
\'Contain\' => \'contain\', ';
my $regex = qr/[\'\"](.*)[\'\"]\s*=>\s*(.*),*\s/mp;
my $subst = '$2\\t\\t\\t\\t\\t\\t=> __(\'$1\', \'default\'),\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";