import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\'\\\"](.*)[\\'\\\"]\\s*=>\\s*(.*),*\\s";
final String string = "'Default - Auto' => '', \n"
+ " 'Cover' => 'cover', \n"
+ " 'Contain' => 'contain', ";
final String subst = "$2\\t\\t\\t\\t\\t\\t=> __('$1', 'default'),\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}