# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$"
test_str = ("# with k/v pairs declared\n"
"http-metrics;http-metrics=https,grpc=http;\n"
"http-metrics;http-metrics=https,grpc=https;\n"
"http-metrics;http-metrics=,grpc=https;\n"
"http-metrics;http-metrics=http,grpc=http,ssh=http;\n"
"http-metrics;http-metrics=http,grpc=https,ssh=http;\n"
"http-metrics;http-metrics=,grpc=https,ssh=;\n"
"http-metrics;;http-metrics=https,grpc=http,ssh=http\n"
"http-metrics;;http-metrics=https,grpc=https,ssh=http\n"
"http-metrics;;http-metrics=https,grpc=https,ssh=https\n"
"http-metrics;;http-metrics=http,grpc=http,ssh=http\n"
"http-metrics;;http-metrics=http,grpc=https,ssh=http\n"
"http-metrics;;http-metrics=http,grpc=https,ssh=https\n"
"grpc;http-metrics=https,grpc=http,ssh=http;\n"
"grpc;http-metrics=https,grpc=https,ssh=http;\n"
"grpc;http-metrics=https,grpc=https,ssh=https;\n"
"grpc;http-metrics=http,grpc=http,ssh=http;\n"
"grpc;http-metrics=http,grpc=https,ssh=http;\n"
"grpc;http-metrics=http,grpc=https,ssh=https;\n\n"
"# without k/v pairs declared \n"
"http-metrics;https;\n"
"http-metrics;;https\n"
"http-metrics;http;https\n"
";;https\n"
";;\n"
";http;\n"
";;http")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.