using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$";
string input = @"# with k/v pairs declared
http-metrics;http-metrics=https,grpc=http;
http-metrics;http-metrics=https,grpc=https;
http-metrics;http-metrics=,grpc=https;
http-metrics;http-metrics=http,grpc=http,ssh=http;
http-metrics;http-metrics=http,grpc=https,ssh=http;
http-metrics;http-metrics=,grpc=https,ssh=;
http-metrics;;http-metrics=https,grpc=http,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=https
http-metrics;;http-metrics=http,grpc=http,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=https
grpc;http-metrics=https,grpc=http,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=https;
grpc;http-metrics=http,grpc=http,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=https;
# without k/v pairs declared
http-metrics;https;
http-metrics;;https
http-metrics;http;https
;;https
;;
;http;
;;http";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}