use strict;
my $str = '# with k/v pairs declared
http-metrics;http-metrics=https,grpc=http;
http-metrics;http-metrics=https,grpc=https;
http-metrics;http-metrics=,grpc=https;
http-metrics;http-metrics=http,grpc=http,ssh=http;
http-metrics;http-metrics=http,grpc=https,ssh=http;
http-metrics;http-metrics=,grpc=https,ssh=;
http-metrics;;http-metrics=https,grpc=http,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=https
http-metrics;;http-metrics=http,grpc=http,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=https
grpc;http-metrics=https,grpc=http,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=https;
grpc;http-metrics=http,grpc=http,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=https;
# without k/v pairs declared
http-metrics;https;
http-metrics;;https
http-metrics;http;https
;;https
;;
;http;
;;http';
my $regex = qr/^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}