const regex = /^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;,\\n]*);.*(\\b\\1\\b=|;)(https?)(,.*)?$', 'gm')
const str = `# with k/v pairs declared
http-metrics;http-metrics=https,grpc=http;
http-metrics;http-metrics=https,grpc=https;
http-metrics;http-metrics=,grpc=https;
http-metrics;http-metrics=http,grpc=http,ssh=http;
http-metrics;http-metrics=http,grpc=https,ssh=http;
http-metrics;http-metrics=,grpc=https,ssh=;
http-metrics;;http-metrics=https,grpc=http,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=https
http-metrics;;http-metrics=http,grpc=http,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=https
grpc;http-metrics=https,grpc=http,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=https;
grpc;http-metrics=http,grpc=http,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=https;
# without k/v pairs declared
http-metrics;https;
http-metrics;;https
http-metrics;http;https
;;https
;;
;http;
;;http`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}