import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;,\\n]*);.*(\\b\\1\\b=|;)(https?)(,.*)?$";
final String string = "# with k/v pairs declared\n"
+ "http-metrics;http-metrics=https,grpc=http;\n"
+ "http-metrics;http-metrics=https,grpc=https;\n"
+ "http-metrics;http-metrics=,grpc=https;\n"
+ "http-metrics;http-metrics=http,grpc=http,ssh=http;\n"
+ "http-metrics;http-metrics=http,grpc=https,ssh=http;\n"
+ "http-metrics;http-metrics=,grpc=https,ssh=;\n"
+ "http-metrics;;http-metrics=https,grpc=http,ssh=http\n"
+ "http-metrics;;http-metrics=https,grpc=https,ssh=http\n"
+ "http-metrics;;http-metrics=https,grpc=https,ssh=https\n"
+ "http-metrics;;http-metrics=http,grpc=http,ssh=http\n"
+ "http-metrics;;http-metrics=http,grpc=https,ssh=http\n"
+ "http-metrics;;http-metrics=http,grpc=https,ssh=https\n"
+ "grpc;http-metrics=https,grpc=http,ssh=http;\n"
+ "grpc;http-metrics=https,grpc=https,ssh=http;\n"
+ "grpc;http-metrics=https,grpc=https,ssh=https;\n"
+ "grpc;http-metrics=http,grpc=http,ssh=http;\n"
+ "grpc;http-metrics=http,grpc=https,ssh=http;\n"
+ "grpc;http-metrics=http,grpc=https,ssh=https;\n\n"
+ "# without k/v pairs declared \n"
+ "http-metrics;https;\n"
+ "http-metrics;;https\n"
+ "http-metrics;http;https\n"
+ ";;https\n"
+ ";;\n"
+ ";http;\n"
+ ";;http";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}