$re = '/^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$/m';
$str = '# with k/v pairs declared
http-metrics;http-metrics=https,grpc=http;
http-metrics;http-metrics=https,grpc=https;
http-metrics;http-metrics=,grpc=https;
http-metrics;http-metrics=http,grpc=http,ssh=http;
http-metrics;http-metrics=http,grpc=https,ssh=http;
http-metrics;http-metrics=,grpc=https,ssh=;
http-metrics;;http-metrics=https,grpc=http,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=http
http-metrics;;http-metrics=https,grpc=https,ssh=https
http-metrics;;http-metrics=http,grpc=http,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=http
http-metrics;;http-metrics=http,grpc=https,ssh=https
grpc;http-metrics=https,grpc=http,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=http;
grpc;http-metrics=https,grpc=https,ssh=https;
grpc;http-metrics=http,grpc=http,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=http;
grpc;http-metrics=http,grpc=https,ssh=https;
# without k/v pairs declared
http-metrics;https;
http-metrics;;https
http-metrics;http;https
;;https
;;
;http;
;;http';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);