#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;,\n]*);.*(\b\1\b=|;)(https?)(,.*)?$"
Local $sString = "# with k/v pairs declared" & @CRLF & _
"http-metrics;http-metrics=https,grpc=http;" & @CRLF & _
"http-metrics;http-metrics=https,grpc=https;" & @CRLF & _
"http-metrics;http-metrics=,grpc=https;" & @CRLF & _
"http-metrics;http-metrics=http,grpc=http,ssh=http;" & @CRLF & _
"http-metrics;http-metrics=http,grpc=https,ssh=http;" & @CRLF & _
"http-metrics;http-metrics=,grpc=https,ssh=;" & @CRLF & _
"http-metrics;;http-metrics=https,grpc=http,ssh=http" & @CRLF & _
"http-metrics;;http-metrics=https,grpc=https,ssh=http" & @CRLF & _
"http-metrics;;http-metrics=https,grpc=https,ssh=https" & @CRLF & _
"http-metrics;;http-metrics=http,grpc=http,ssh=http" & @CRLF & _
"http-metrics;;http-metrics=http,grpc=https,ssh=http" & @CRLF & _
"http-metrics;;http-metrics=http,grpc=https,ssh=https" & @CRLF & _
"grpc;http-metrics=https,grpc=http,ssh=http;" & @CRLF & _
"grpc;http-metrics=https,grpc=https,ssh=http;" & @CRLF & _
"grpc;http-metrics=https,grpc=https,ssh=https;" & @CRLF & _
"grpc;http-metrics=http,grpc=http,ssh=http;" & @CRLF & _
"grpc;http-metrics=http,grpc=https,ssh=http;" & @CRLF & _
"grpc;http-metrics=http,grpc=https,ssh=https;" & @CRLF & _
"" & @CRLF & _
"# without k/v pairs declared " & @CRLF & _
"http-metrics;https;" & @CRLF & _
"http-metrics;;https" & @CRLF & _
"http-metrics;http;https" & @CRLF & _
";;https" & @CRLF & _
";;" & @CRLF & _
";http;" & @CRLF & _
";;http"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")