import Foundation
let pattern = #"[A-Z]+(\d+)_[A-Z]+_[A-Z]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"BREAK1_UPPER_QUANTITY"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Staffel \1 Obergrenze"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}