// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]+(\d+)_[A-Z]+_[A-Z]+").unwrap();
let string = "BREAK1_UPPER_QUANTITY";
let substitution = "Staffel \\1 Obergrenze";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}