import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]+(\\d+)_[A-Z]+_[A-Z]+";
final String string = "BREAK1_UPPER_QUANTITY";
final String subst = "Staffel \\1 Obergrenze";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}