# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-Z]+(\d+)_[A-Z]+_[A-Z]+/Staffel \1 Obergrenze/;t' <<< "BREAK1_UPPER_QUANTITY"