$re = '/[A-Z]+(\d+)_[A-Z]+_[A-Z]+/';
$str = 'BREAK1_UPPER_QUANTITY';
$subst = "Staffel \1 Obergrenze";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;