re = /[A-Z]+(\d+)_[A-Z]+_[A-Z]+/
str = 'BREAK1_UPPER_QUANTITY'
subst = 'Staffel \\1 Obergrenze'
result = str.sub(re, subst)
# Print the result of the substitution
puts result