package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]+(\d+)_[A-Z]+_[A-Z]+`)
var str = []byte(`BREAK1_UPPER_QUANTITY`)
var substitution = []byte("Staffel \1 Obergrenze")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}