import Foundation
let pattern = #"-\s?\d{4}[\s*]*\w*\s?\w*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\Diageo_Catalogues\CATALOGUES_SEPTEMBER_2015\test for WE\Haig Club - 2015 Global eu"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}