$re = '/-\s?\d{4}[\s*]*\w*\s?\w*/';
$str = '\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - 2015 Global eu';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);