#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-\s?\d{4}[\s*]*\w*\s?\w*"
Local $sString = "\Diageo_Catalogues\CATALOGUES_SEPTEMBER_2015\test for WE\Haig Club - 2015 Global eu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")