package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-\s?\d{4}[\s*]*\w*\s?\w*`)
var str = `\Diageo_Catalogues\CATALOGUES_SEPTEMBER_2015\test for WE\Haig Club - 2015 Global eu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}