const regex = /-\s?\d{4}[\s*]*\w*\s?\w*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\s?\\d{4}[\\s*]*\\w*\\s?\\w*', '')
const str = `\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - 2015 Global eu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}