re = /-\s?\d{4}[\s*]*\w*\s?\w*/
str = '\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - 2015 Global eu'
# Print the match result
str.match(re) do |match|
puts match.to_s
end