// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-\s?\d{4}[\s*]*\w*\s?\w*").unwrap();
let string = "\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - 2015 Global eu";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}