// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+84|0)[1-9][0-9]{8,9}$").unwrap();
let string = "0775844073
07756440730
+84775844073
123
0000000000
1234567890
161165656565";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}