using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+84|0)[1-9][0-9]{8,9}$";
string input = @"0775844073
07756440730
+84775844073
123
0000000000
1234567890
161165656565";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}