$re = '/^(\+84|0)[1-9][0-9]{8,9}$/m';
$str = '0775844073
07756440730
+84775844073
123
0000000000
1234567890
161165656565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);