const regex = /^(\+84|0)[1-9][0-9]{8,9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+84|0)[1-9][0-9]{8,9}$', 'gm')
const str = `0775844073
07756440730
+84775844073
123
0000000000
1234567890
161165656565`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}