package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+84|0)[1-9][0-9]{8,9}$`)
var str = `0775844073
07756440730
+84775844073
123
0000000000
1234567890
161165656565`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}