#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+84|0)[1-9][0-9]{8,9}$"
Local $sString = "0775844073" & @CRLF & _
"07756440730" & @CRLF & _
"+84775844073" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"0000000000" & @CRLF & _
"1234567890" & @CRLF & _
"161165656565"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")