import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+84|0)[1-9][0-9]{8,9}$";
final String string = "0775844073\n"
+ "07756440730\n"
+ "+84775844073\n\n"
+ "123\n"
+ "0000000000\n"
+ "1234567890\n"
+ "161165656565";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}