import Foundation
let pattern = #"^([a-zA-Z]+\w*)[ \t]*=(?!=).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
aa = 100
bb=100
s=2
a90=0
a91 =0
a92 = 0
app = Mgr()
app2 = mary()
app3 = mary(x=2)
# below should NOT match
# a = 100
hello there
fred(xx=100)
def mary(xx=100)
77=0
88 = 0
a93 == 0
a94 0
a95 0 =
if __name__ == "__main__":
app.run(host="0.0.0.0", port=8000)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)