import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]+\\w*)[ \\t]*=(?!=).+";
final String string = "aa = 100\n"
+ "bb=100\n"
+ "s=2\n"
+ "a90=0\n"
+ "a91 =0\n"
+ "a92 = 0\n"
+ "app = Mgr()\n"
+ "app2 = mary()\n"
+ "app3 = mary(x=2)\n\n"
+ "# below should NOT match\n\n"
+ "# a = 100\n"
+ "hello there\n"
+ "fred(xx=100)\n"
+ "def mary(xx=100)\n"
+ "77=0\n"
+ "88 = 0\n"
+ "a93 == 0\n"
+ "a94 0\n"
+ "a95 0 =\n"
+ "if __name__ == \"__main__\":\n"
+ " app.run(host=\"0.0.0.0\", port=8000)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}