using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]+\w*)[ \t]*=(?!=).+";
string input = @"aa = 100
bb=100
s=2
a90=0
a91 =0
a92 = 0
app = Mgr()
app2 = mary()
app3 = mary(x=2)
# below should NOT match
# a = 100
hello there
fred(xx=100)
def mary(xx=100)
77=0
88 = 0
a93 == 0
a94 0
a95 0 =
if __name__ == ""__main__"":
app.run(host=""0.0.0.0"", port=8000)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}