const regex = new RegExp('^([a-zA-Z]+\\w*)[ \\t]*=(?!=).+', 'gm')
const str = `aa = 100
bb=100
s=2
a90=0
a91 =0
a92 = 0
app = Mgr()
app2 = mary()
app3 = mary(x=2)
# below should NOT match
# a = 100
hello there
fred(xx=100)
def mary(xx=100)
77=0
88 = 0
a93 == 0
a94 0
a95 0 =
if __name__ == "__main__":
app.run(host="0.0.0.0", port=8000)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}