# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-zA-Z]+\w*)[ \t]*=(?!=).+"
test_str = ("aa = 100\n"
"bb=100\n"
"s=2\n"
"a90=0\n"
"a91 =0\n"
"a92 = 0\n"
"app = Mgr()\n"
"app2 = mary()\n"
"app3 = mary(x=2)\n\n"
"# below should NOT match\n\n"
"# a = 100\n"
"hello there\n"
"fred(xx=100)\n"
"def mary(xx=100)\n"
"77=0\n"
"88 = 0\n"
"a93 == 0\n"
"a94 0\n"
"a95 0 =\n"
"if __name__ == \"__main__\":\n"
" app.run(host=\"0.0.0.0\", port=8000)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.