re = /^([a-zA-Z]+\w*)[ \t]*=(?!=).+/m
str = 'aa = 100
bb=100
s=2
a90=0
a91 =0
a92 = 0
app = Mgr()
app2 = mary()
app3 = mary(x=2)
# below should NOT match
# a = 100
hello there
fred(xx=100)
def mary(xx=100)
77=0
88 = 0
a93 == 0
a94 0
a95 0 =
if __name__ == "__main__":
app.run(host="0.0.0.0", port=8000)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end