import Foundation
let pattern = #"(?<=_)(\d+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)