use strict;
my $str = 'I have 104 digits
This is supposed to remove digits from the suffix like 501
This only works if the suffix is preceeded by an underscore, like this_420';
my $regex = qr/(?<=_)(\d+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";