import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=_)(\\d+$)";
final String string = "I have 104 digits\n\n"
+ "This is supposed to remove digits from the suffix like 501\n\n"
+ "This only works if the suffix is preceeded by an underscore, like this_420";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}